summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@colm.net>2019-12-27 19:35:03 +0200
committerAdrian Thurston <thurston@colm.net>2019-12-27 19:45:00 +0200
commit218df582dd34efb7dae271c587ab5a97c10398a4 (patch)
treedc4b8e88522b2cdaeec655e4cf5078be03f81197 /configure.ac
parent76c61145948c8c7918d3f1b3a6a1e91be457629c (diff)
downloadcolm-218df582dd34efb7dae271c587ab5a97c10398a4.tar.gz
ragel: check that javac works
If ulimit -a is used, javac may not run. Added a configure check to verify it runs. refs #92
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2a124740..09af2894 100644
--- a/configure.ac
+++ b/configure.ac
@@ -263,6 +263,24 @@ AC_PATH_PROG([JULIA_BIN], [julia])
AC_PATH_PROG([GNUSTEP_CONFIG], [gnustep-config])
dnl
+dnl Java test cases are now requring a large virtual address space. On systems
+dnl where this is limited by ulimit, java will fail to run.
+dnl
+
+if test "x$JAVAC_BIN" != x; then
+ echo 'class conftest { public static void main( String[] args ) { } }' > conftest.java
+ echo -n "checking if javac is able to compile programs ... "
+ if sh -c "$JAVAC_BIN conftest.java" >>config.log 2>&1; then
+ echo "yes"
+ else
+ echo "no"
+ JAVAC_BIN=""
+ fi
+ rm -f conftest.java conftest.class
+fi
+
+
+dnl
dnl Julia requires a large virtual address space. On systems where this is
dnl limited by ulimit, julia will fail to run.
dnl