summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@colm.net>2021-11-13 10:40:38 -0800
committerAdrian Thurston <thurston@colm.net>2021-11-13 10:40:38 -0800
commit2554e934d31e50c2cc72a2ca2a0a3dd85f62c17d (patch)
treefcba6aa1c33db3b5394d1f4c08a2e58f941de032 /configure.ac
parenta3d6031b7dd2b4975f37b64b1a08705e37c71356 (diff)
downloadcolm-2554e934d31e50c2cc72a2ca2a0a3dd85f62c17d.tar.gz
always default to not build the manual
In most build scenarios I now find myself in, the depenencies required for building the manual are not available. There are many uncommon packages to grab. It seems better to build the manual only when asked for explicitly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 3 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 4f4c4d1a..836ab9f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -83,15 +83,9 @@ AC_CHECK_PROG([ASCIIDOC], [asciidoc], [asciidoc])
AC_CHECK_PROG([PYGMENTIZE], [pygmentize], [pygmentize])
AM_CONDITIONAL([BUILD_MANUAL], [test "x$ASCIIDOC" != x && test "x$PYGMENTIZE" != x])
-dnl Choose a default for the build_manual var. If the dist file is present in
-dnl the root then default to no, otherwise go for it.
-if test "$cross_compiling" != "yes"; then
-AC_CHECK_FILES( [$srcdir/DIST],
- [. $srcdir/DIST;],
- [build_manual=yes; ] )
-else
-AS_IF([test -a "$srcdir/DIST"], [build_manual="yes"], [])
-fi
+dnl Do not build the manual by default. Most of the time the dependencies are
+dnl not available, as they can be quite big installs.
+build_manual=no
dnl
dnl Enable arg to explicitly control the building of the manual