summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDonald Hoskins <grommish@gmail.com>2020-12-23 20:39:06 -0500
committerDonald Hoskins <grommish@gmail.com>2020-12-23 20:39:06 -0500
commit25f93dbfae301d25372c91bd00e6cce836b0886f (patch)
tree88c75c933a16297aa2229670c8bda6f9af51a2bd /configure.ac
parentc086031208751d26f09d6177e6bb82923dc852fa (diff)
downloadcolm-25f93dbfae301d25372c91bd00e6cce836b0886f.tar.gz
Correct for cross-compiling
Signed-off-by: Donald Hoskins <grommish@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d4723aba..f0f9282b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,9 +85,13 @@ AM_CONDITIONAL([BUILD_MANUAL], [test "x$ASCIIDOC" != x && test "x$PYGMENTIZE" !=
dnl Choose a default for the build_manual var. If the dist file is present in
dnl the root then default to no, otherwise go for it.
+if test "$cross_compiling" != "yes"; then
AC_CHECK_FILES( [$srcdir/DIST],
[. $srcdir/DIST;],
[build_manual=yes; ] )
+else
+AS_IF([test -a "$srcdir/DIST"], [build_manual="yes"], [])
+fi
dnl
dnl Enable arg to explicitly control the building of the manual
@@ -390,8 +394,13 @@ AC_ARG_WITH(colm,
EXTERNAL_COLM="$withval"
EXTERNAL_INC="-I$withval/include"
EXTERNAL_LIBS="-L$withval/lib"
+ if test "$cross_compiling" != "yes"; then
AC_CHECK_FILES(["$EXTERNAL_COLM/bin/colm"], [],
[AC_ERROR(["could not find $EXTERNAL_COLM/bin/colm"])])
+ else
+ AS_IF([test -a "$EXTERNAL_COLM/bin/colm"], [],
+ AC_ERROR(["could not find $EXTERNAL_COLM/bin/colm"]))
+ fi
],
[]
)