summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@colm.net>2019-10-15 17:49:25 -0300
committerAdrian Thurston <thurston@colm.net>2019-10-15 18:01:10 -0300
commit49ad3f194f4b188abc663c83b05ba7908b773afa (patch)
tree7ffea2eaabe9ba9bc8c368609b52ca5f7e07c41f /configure.ac
parentb017550ee702067d43c9b20a22ec75997e270d25 (diff)
downloadcolm-49ad3f194f4b188abc663c83b05ba7908b773afa.tar.gz
added --with-colm option for building colm parser with an external colm
By default the package will bootstrap, but when working on the parser it is possible to break building of colm itself. This is a major nuisance, so allow building with an external colm, skipping the bootstrap process.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index bbf267bd..932e3af3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -275,12 +275,22 @@ SED_SUBST="$SED_SUBST -e 's|@CRACK_BIN@|${CRACK_BIN}|g'"
AC_SUBST(CRACK_BIN)
+dnl Generic dependency specification.
+AC_ARG_WITH(colm,
+ [AC_HELP_STRING([--with-colm], [colm install to build bootstrap programs])],
+ [EXTERNAL_COLM="$withval"],
+ []
+)
-AC_SUBST(SED_SUBST)
+AM_CONDITIONAL([EXTERNAL_COLM], [test "x$EXTERNAL_COLM" != x])
+AC_SUBST(EXTERNAL_COLM)
-AC_CONFIG_HEADERS([src/config.h colm/defs.h])
+dnl
+dnl Wrap up.
+dnl
-dnl write output files
+AC_SUBST(SED_SUBST)
+AC_CONFIG_HEADERS([src/config.h colm/defs.h])
AC_OUTPUT([
Makefile
aapl/Makefile