summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@colm.net>2019-09-19 19:58:31 -0600
committerAdrian Thurston <thurston@colm.net>2019-09-19 19:58:31 -0600
commitf625a8d45a2def866607b3f8903aa8c31f43f834 (patch)
treec24f62ac8057a87a58cb61e5a0d269543a74a9dc /configure.ac
parent77fd83b6fca318095329ef4398911829e6753184 (diff)
downloadcolm-f625a8d45a2def866607b3f8903aa8c31f43f834.tar.gz
set the BUILD_MANUAL conditional after checking --enable-manual
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index e1882839..bbf267bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,15 +44,6 @@ AC_CHECK_SIZEOF([unsigned long])
AC_CHECK_SIZEOF([unsigned long long])
AC_CHECK_HEADERS([sys/mman.h sys/wait.h unistd.h])
-dnl Choose a default for the build_manual var. If the dist file is present in
-dnl the root then default to no, otherwise go for it.
-AC_CHECK_FILES( [$srcdir/DIST],
- [. $srcdir/DIST;],
- [build_manual=yes; ] )
-
-dnl Set to true if the manual should be built.
-AM_CONDITIONAL(BUILD_MANUAL, [test "x$build_manual" = "xyes"])
-
AC_CHECK_SIZEOF([long])
dnl Generic dependency specification.
@@ -97,6 +88,12 @@ AC_CHECK_PROG([ASCIIDOC], [asciidoc], [asciidoc])
AC_CHECK_PROG([PYGMENTIZE], [pygmentize], [pygmentize])
AM_CONDITIONAL([BUILD_MANUAL], [test "x$ASCIIDOC" != x && test "x$PYGMENTIZE" != x])
+dnl Choose a default for the build_manual var. If the dist file is present in
+dnl the root then default to no, otherwise go for it.
+AC_CHECK_FILES( [$srcdir/DIST],
+ [. $srcdir/DIST;],
+ [build_manual=yes; ] )
+
dnl
dnl Enable arg to explicitly control the building of the manual
dnl
@@ -130,6 +127,9 @@ if test "x$build_manual" = "xyes"; then
fi
fi
+dnl Set to true if the manual should be built.
+AM_CONDITIONAL(BUILD_MANUAL, [test "x$build_manual" = "xyes"])
+
dnl
dnl Build the program? ( no means just build libfsm )
dnl