summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@colm.net>2020-12-23 08:41:21 -0800
committerAdrian Thurston <thurston@colm.net>2020-12-23 08:41:21 -0800
commit20b866cd3bb11a8d26099fbc081b50e22e24c4e7 (patch)
tree8939f12b33df270062420c14ed50fba9885b01af /src/Makefile.am
parent2397df53d2549e58ad3638542185413c57ea0c5d (diff)
downloadcolm-20b866cd3bb11a8d26099fbc081b50e22e24c4e7.tar.gz
removed duplicate version COLM_VERSION
This was left over from the time colm and ragel were in one repos. Now just use VERSION and PUBDATE.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bc43d75d..1341a41c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -44,7 +44,7 @@ lib_LTLIBRARIES = libcolm.la
noinst_LIBRARIES = libprog.a
libcolm_la_SOURCES = $(RUNTIME_SRC)
-libcolm_la_LDFLAGS = -release ${COLM_VERSION} -no-undefined
+libcolm_la_LDFLAGS = -release ${VERSION} -no-undefined
if LINKER_NO_UNDEFINED
libcolm_la_LDFLAGS += -Wl,--no-undefined
@@ -196,8 +196,8 @@ include/colm:
ln -s .. include/colm
version.h: Makefile
- echo '#define COLM_VERSION "$(COLM_VERSION)"' > version.h
- echo '#define COLM_PUBDATE "$(COLM_PUBDATE)"' >> version.h
+ echo '#define VERSION "$(VERSION)"' > version.h
+ echo '#define PUBDATE "$(PUBDATE)"' >> version.h
config.h: ../src/config.h
cp ../src/config.h ./