summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@complang.org>2016-06-29 12:49:31 -0400
committerAdrian Thurston <thurston@complang.org>2016-06-29 12:49:31 -0400
commitd8516da36be899e2f172881819612c660b05b8b3 (patch)
treeced2713c987b6190ca25daf3c58574c9ad21f62f /src/Makefile.am
parent57b67570de7c0a677531bf889bb4761cd0a97124 (diff)
downloadcolm-d8516da36be899e2f172881819612c660b05b8b3.tar.gz
don't build 'p' and 'd' versions of the lib (production & debug), just libcolm
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 6 insertions, 9 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5fd9dfe5..81c22d35 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -34,15 +34,12 @@ RUNTIME_HDR = \
bytecode.h config.h defs.h debug.h pool.h input.h \
pdarun.h map.h type.h tree.h struct.h program.h colm.h internal.h
-lib_LTLIBRARIES = libcolmp.la libcolmd.la
+lib_LTLIBRARIES = libcolm.la
noinst_LIBRARIES = libprog.a
-libcolmp_la_SOURCES = $(RUNTIME_SRC)
-libcolmp_la_LDFLAGS = -release ${PACKAGE_VERSION}
-
-libcolmd_la_SOURCES = $(RUNTIME_SRC)
-libcolmd_la_LDFLAGS = -release ${PACKAGE_VERSION}
+libcolm_la_SOURCES = $(RUNTIME_SRC)
+libcolm_la_LDFLAGS = -release ${PACKAGE_VERSION}
common_CFLAGS = \
-Wall \
@@ -67,7 +64,7 @@ libprog_a_CXXFLAGS = $(common_CFLAGS)
bootstrap0_CXXFLAGS = $(common_CFLAGS) -DCONS_INIT
bootstrap0_SOURCES = consinit.cc consinit.h main.cc
-bootstrap0_LDADD = libprog.a libcolmd.la
+bootstrap0_LDADD = libprog.a libcolm.la
bootstrap1_CXXFLAGS = $(common_CFLAGS) -DLOAD_INIT
bootstrap1_CFLAGS = $(common_CFLAGS)
@@ -75,7 +72,7 @@ bootstrap1_SOURCES = \
loadinit.h loadinit.cc main.cc
nodist_bootstrap1_SOURCES = \
gen/if1.h gen/if1.cc gen/parse1.c
-bootstrap1_LDADD = libprog.a libcolmd.la
+bootstrap1_LDADD = libprog.a libcolm.la
colm_CXXFLAGS = $(common_CFLAGS) -DLOAD_COLM
colm_CFLAGS = $(common_CFLAGS)
@@ -83,7 +80,7 @@ colm_SOURCES = \
loadcolm.h loadcolm.cc main.cc
nodist_colm_SOURCES = \
gen/if2.h gen/if2.cc gen/parse2.c
-colm_LDADD = libprog.a libcolmd.la
+colm_LDADD = libprog.a libcolm.la
colmincdir = $(includedir)/colm