summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 08a1c069..cb910b74 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 3.0)
# Read project configuration from configure.ac file
file(STRINGS configure.ac _PROJECT_CONFIGS
- REGEX "(AC_INIT\\()|(PUBDATE=)")
+ REGEX "(AC_INIT\\()")
foreach(_PROJECT_CONFIG ${_PROJECT_CONFIGS})
if(_PROJECT_CONFIG MATCHES "AC_INIT\\(([^,]+)")
string(STRIP ${CMAKE_MATCH_1} PROJECT_NAME)
@@ -10,9 +10,6 @@ foreach(_PROJECT_CONFIG ${_PROJECT_CONFIGS})
if(_PROJECT_CONFIG MATCHES "AC_INIT\\([^,]+,([^\\)]+)")
string(STRIP ${CMAKE_MATCH_1} PROJECT_VERSION)
endif()
- if(_PROJECT_CONFIG MATCHES "PUBDATE=\"([^\"]+)")
- string(STRIP ${CMAKE_MATCH_1} PROJECT_PUBDATE)
- endif()
endforeach()
project(${PROJECT_NAME}