summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 298da146..11b5d00a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -406,6 +406,15 @@ AC_SUBST(EXTERNAL_COLM)
AC_SUBST(EXTERNAL_INC)
AC_SUBST(EXTERNAL_LIBS)
+dnl Check for fopencookie. If available, we will use to avoid leaking FILE structs.
+dnl The result of an fdopen cannot be closed without also closing the fd, so we
+dnl make our own FILE type.
+AC_CHECK_FUNC(fopencookie,
+ [AC_DEFINE([HAVE_FOPENCOOKIE], [1], [have fopencookie])],
+ []
+)
+
+
dnl
dnl Wrap up.
dnl