summaryrefslogtreecommitdiff
path: root/lib/gwp_asan/CMakeLists.txt
diff options
context:
space:
mode:
authorMitch Phillips <mitchphillips@outlook.com>2019-07-16 17:13:02 +0000
committerMitch Phillips <mitchphillips@outlook.com>2019-07-16 17:13:02 +0000
commit882efe25584f52e5e5bfa57da68f9235e4d84b3e (patch)
treeea8ea7549bf0b44663317d9e924b8d82068c6d49 /lib/gwp_asan/CMakeLists.txt
parent5be36990b622b258669ec7c6420de2d64bba58b2 (diff)
downloadcompiler-rt-882efe25584f52e5e5bfa57da68f9235e4d84b3e.tar.gz
Removed -mno-omit-leaf-frame-pointer from flags.
Removes -mno-omit-leaf-frame-pointer from Scudo and GWP-ASan's CFlags. Attempt to fix the sanitizer buildbots. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@366228 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/gwp_asan/CMakeLists.txt')
-rw-r--r--lib/gwp_asan/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/lib/gwp_asan/CMakeLists.txt b/lib/gwp_asan/CMakeLists.txt
index 952acb183..94c5336ce 100644
--- a/lib/gwp_asan/CMakeLists.txt
+++ b/lib/gwp_asan/CMakeLists.txt
@@ -25,8 +25,6 @@ set(GWP_ASAN_CFLAGS -fno-rtti -fno-exceptions -nostdinc++ -pthread)
append_list_if(COMPILER_RT_HAS_FPIC_FLAG -fPIC GWP_ASAN_CFLAGS)
append_list_if(COMPILER_RT_HAS_OMIT_FRAME_POINTER_FLAG -fno-omit-frame-pointer
GWP_ASAN_CFLAGS)
-append_list_if(COMPILER_RT_HAS_OMIT_FRAME_POINTER_FLAG
- -mno-omit-leaf-frame-pointer GWP_ASAN_CFLAGS)
# Remove -stdlib= which is unused when passing -nostdinc++.
string(REGEX REPLACE "-stdlib=[a-zA-Z+]*" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})