summaryrefslogtreecommitdiff
path: root/lib/gwp_asan/CMakeLists.txt
diff options
context:
space:
mode:
authorMitch Phillips <mitchphillips@outlook.com>2019-06-05 01:27:39 +0000
committerMitch Phillips <mitchphillips@outlook.com>2019-06-05 01:27:39 +0000
commitb08f843699053d0a9365926f8f44ff3cd72ffdac (patch)
tree4ad37e325b6ed4ad7302ec1b34d094a74b89bb5b /lib/gwp_asan/CMakeLists.txt
parent4d2285b94a05a2aa743c6e52daa0c17c6603395e (diff)
downloadcompiler-rt-b08f843699053d0a9365926f8f44ff3cd72ffdac.tar.gz
Changed force build of GWP-ASan options parser to be statically
linked instead of dynamic. This should help resolve a downstream build order issue against libc++. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@362566 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/gwp_asan/CMakeLists.txt')
-rw-r--r--lib/gwp_asan/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/gwp_asan/CMakeLists.txt b/lib/gwp_asan/CMakeLists.txt
index 771192f23..c53152450 100644
--- a/lib/gwp_asan/CMakeLists.txt
+++ b/lib/gwp_asan/CMakeLists.txt
@@ -77,7 +77,7 @@ if (COMPILER_RT_HAS_GWP_ASAN)
foreach(arch ${GWP_ASAN_SUPPORTED_ARCH})
add_compiler_rt_runtime(
clang_rt.gwp_asan_options_parser
- SHARED
+ STATIC
ARCHS ${arch}
SOURCES ${GWP_ASAN_OPTIONS_PARSER_SOURCES}
ADDITIONAL_HEADERS ${GWP_ASAN_OPTIONS_PARSER_HEADERS}