summaryrefslogtreecommitdiff
path: root/lib/hwasan/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeniy Stepanov <eugeni.stepanov@gmail.com>2018-08-10 16:38:57 +0000
committerEvgeniy Stepanov <eugeni.stepanov@gmail.com>2018-08-10 16:38:57 +0000
commit6ede64d9baec14360789964f76630744aefdc6e2 (patch)
tree291113d290cf4f2daa3bae85160addf224d894e6 /lib/hwasan/CMakeLists.txt
parent4f7c361dfbe533e883737844251598152333f087 (diff)
downloadcompiler-rt-6ede64d9baec14360789964f76630744aefdc6e2.tar.gz
[hwasan] Remove liblog dependency.
HWASan will not run on older Android releases where we use __android_log_write for logging. This dependency is also harmful in the case when libc itself depends on hwasan, because it creates a loop of libc -> hwasan -> liblog -> libc which makes liblog vs libc initialization order undetermined. Without liblog the loop is just libc -> hwasan -> libc and any init order issues can be solved in hwasan. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@339449 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/hwasan/CMakeLists.txt')
-rw-r--r--lib/hwasan/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/hwasan/CMakeLists.txt b/lib/hwasan/CMakeLists.txt
index 42bf4366f..6d1682bbf 100644
--- a/lib/hwasan/CMakeLists.txt
+++ b/lib/hwasan/CMakeLists.txt
@@ -47,7 +47,6 @@ append_list_if(COMPILER_RT_HAS_LIBDL dl HWASAN_DYNAMIC_LIBS)
append_list_if(COMPILER_RT_HAS_LIBRT rt HWASAN_DYNAMIC_LIBS)
append_list_if(COMPILER_RT_HAS_LIBM m HWASAN_DYNAMIC_LIBS)
append_list_if(COMPILER_RT_HAS_LIBPTHREAD pthread HWASAN_DYNAMIC_LIBS)
-append_list_if(COMPILER_RT_HAS_LIBLOG log HWASAN_DYNAMIC_LIBS)
# Static runtime library.
add_compiler_rt_component(hwasan)