summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <vonosmas@gmail.com>2014-11-05 22:44:36 +0000
committerAlexey Samsonov <vonosmas@gmail.com>2014-11-05 22:44:36 +0000
commit2eb3d6daf27d0698811912bf62cc113cbebca8e0 (patch)
tree87896d94c29ba4d174bfa7f907c355bb7bc06584 /lib/sanitizer_common/tests/CMakeLists.txt
parent822401938dff8288be4582b1c5c962e009479d43 (diff)
downloadcompiler-rt-2eb3d6daf27d0698811912bf62cc113cbebca8e0.tar.gz
[Sanitizer] Introduce generic stack frame rendering machinery
Summary: This commit introduces function __sanitizer::RenderFrame() that allows to render the contents of AddressInfo (essentially, symbolized stack frame) using the custom format string. This function can be used to implement stack frame formatting for both ThreadSanitizer and generic StackTrace::Print(), used in another places. This paves the way towards allowing user to control the format of stack frames, obtaining them in any format he desires, and/or enforcing the consistent output from all sanitizers. Test Plan: compiler-rt test suite Reviewers: kcc Reviewed By: kcc Subscribers: llvm-commits Differential Revision: http://reviews.llvm.org/D6140 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@221409 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/tests/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/sanitizer_common/tests/CMakeLists.txt b/lib/sanitizer_common/tests/CMakeLists.txt
index c8989236e..bb7a399b0 100644
--- a/lib/sanitizer_common/tests/CMakeLists.txt
+++ b/lib/sanitizer_common/tests/CMakeLists.txt
@@ -21,6 +21,7 @@ set(SANITIZER_UNITTESTS
sanitizer_printf_test.cc
sanitizer_procmaps_test.cc
sanitizer_stackdepot_test.cc
+ sanitizer_stacktrace_printer_test.cc
sanitizer_stacktrace_test.cc
sanitizer_stoptheworld_test.cc
sanitizer_suppressions_test.cc