summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorHans Wennborg <hans@hanshq.net>2018-08-29 12:40:29 +0000
committerHans Wennborg <hans@hanshq.net>2018-08-29 12:40:29 +0000
commit813e6b2d3004f847c095ace6939533059fa2eada (patch)
treec74717639bf9df86f38449a0b1b353adb0575340 /lib/sanitizer_common/tests/CMakeLists.txt
parente701be565af9b92dfd509cea941b660b51cb58f8 (diff)
downloadcompiler-rt-813e6b2d3004f847c095ace6939533059fa2eada.tar.gz
Revert r340884 "Add a RingBuffer class to sanitizer_common"
The test doesn't pass on Windows, where sizeof(long) == 4 also on 64-bit, and so it isn't a multiple of sizeof(void*). This also reverts the follow-up r340886. > Summary: a constrained RingBuffer optimized for fast push > > Reviewers: eugenis > > Reviewed By: eugenis > > Subscribers: kubamracek, mgorny, delcypher, #sanitizers, llvm-commits > > Differential Revision: https://reviews.llvm.org/D51196 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@340924 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/tests/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/tests/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/sanitizer_common/tests/CMakeLists.txt b/lib/sanitizer_common/tests/CMakeLists.txt
index 4642c59ec..401682baa 100644
--- a/lib/sanitizer_common/tests/CMakeLists.txt
+++ b/lib/sanitizer_common/tests/CMakeLists.txt
@@ -26,7 +26,6 @@ set(SANITIZER_UNITTESTS
sanitizer_posix_test.cc
sanitizer_printf_test.cc
sanitizer_procmaps_test.cc
- sanitizer_ring_buffer_test.cc
sanitizer_quarantine_test.cc
sanitizer_stackdepot_test.cc
sanitizer_stacktrace_printer_test.cc