summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVedant Kumar <vsk@apple.com>2017-08-30 19:29:11 +0000
committerVedant Kumar <vsk@apple.com>2017-08-30 19:29:11 +0000
commit30b8ae261ee9071c0e9ada8b35a01bd73e8dcadb (patch)
tree60990e08ce343d078ba7f4b8ce6832c06e705348 /test/CMakeLists.txt
parente5229ff180fc2fe4d5f8a364d66609509d959d2e (diff)
downloadcompiler-rt-30b8ae261ee9071c0e9ada8b35a01bd73e8dcadb.tar.gz
[fuzzer] Don't enable tests when the fuzzer isn't built
Should fix: http://green.lab.llvm.org/green/job/clang-stage2-coverage-R_build/1527 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@312157 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index ade658a2c..2e344056f 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -58,7 +58,10 @@ if(COMPILER_RT_CAN_EXECUTE_TESTS)
# CFI tests require diagnostic mode, which is implemented in UBSan.
compiler_rt_test_runtime(ubsan cfi)
compiler_rt_test_runtime(sanitizer_common)
- compiler_rt_test_runtime(fuzzer)
+
+ if(COMPILER_RT_BUILD_LIBFUZZER)
+ compiler_rt_test_runtime(fuzzer)
+ endif()
foreach(sanitizer ${COMPILER_RT_SANITIZERS_TO_BUILD})
# cfi testing is gated on ubsan