summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRob Dennis <rdennis@gmail.com>2014-04-04 23:29:18 -0400
committerRob Dennis <rdennis@gmail.com>2014-04-04 23:29:18 -0400
commit12e56d8f5a9f75f3026a3e9b0461793b77a8ad4e (patch)
treeb39c176af0457ab0bb8bd674bc0b4d8345dbddec /setup.py
parente36be928ae339c57b99fe5ec2f9810a3e3c12340 (diff)
parent54a2572fb9d6c9b1f63585938ad246ddada49982 (diff)
downloadconfigobj-git-12e56d8f5a9f75f3026a3e9b0461793b77a8ad4e.tar.gz
Merge pull request #47 from robdennis/master
refactored version numbers and bumped to 5.0.3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 9 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 36abfad..585dafe 100644
--- a/setup.py
+++ b/setup.py
@@ -10,18 +10,22 @@
# This software is licensed under the terms of the BSD license.
# http://opensource.org/licenses/BSD-3-Clause
+import os
import sys
from distutils.core import setup
+# a simple import wouldn't work if we moved towards a package with __init__
+from _version import __version__
if sys.version_info < (2, 6):
print('for python versions < 2.6 use configobj '
'version 4.7.2')
sys.exit(1)
-# TODO - #20 - refactor the way we do versions
-VERSION = '5.0.2'
+__here__ = os.path.abspath(os.path.dirname(__file__))
+
+VERSION = __version__
NAME = 'configobj'
-MODULES = 'configobj', 'validate'
+MODULES = 'configobj', 'validate', '_version'
DESCRIPTION = 'Config file reading, writing and validation.'
@@ -47,6 +51,8 @@ It has lots of other features though :
* The order of keys/sections is preserved
* Powerful ``unrepr`` mode for storing/retrieving Python data-types
+| Release 5.0.3 corrects errors related to the incorrectly handling unicode
+| encoding and writing out files
| Release 5.0.2 adds a specific error message when trying to install on
| Python versions older than 2.5
| Release 5.0.1 fixes a regression with unicode conversion not happening