summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRob Dennis <rdennis@gmail.com>2014-04-04 22:29:14 -0400
committerRob Dennis <rdennis@gmail.com>2014-04-04 22:29:14 -0400
commit652f5e73f5ec714b3ec88c24afad8fc0f4f4b33a (patch)
treea6614f1ecde3d98784a67cb562f28155bcafc6b4 /setup.py
parentf4f18dd9120274ef7260de31134ab6044f8a4fff (diff)
downloadconfigobj-git-652f5e73f5ec714b3ec88c24afad8fc0f4f4b33a.tar.gz
issue #20, #46 - refactored version numbers and bumped to 5.0.3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 11 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index cc423ab..0e0babd 100644
--- a/setup.py
+++ b/setup.py
@@ -10,6 +10,7 @@
# This software is licensed under the terms of the BSD license.
# http://opensource.org/licenses/BSD-3-Clause
+import os
import sys
from distutils.core import setup
@@ -18,8 +19,14 @@ if sys.version_info < (2, 6):
'version 4.7.2')
sys.exit(1)
-# TODO - #20 - refactor the way we do versions
-VERSION = '5.0.2'
+__here__ = os.path.abspath(os.path.dirname(__file__))
+
+# http://stackoverflow.com/a/16084844/171094
+with open(os.path.join(__here__, '_version.py')) as version:
+ exec(version.read())
+# __version__ is now defined
+
+VERSION = __version__
NAME = 'configobj'
MODULES = 'configobj', 'validate'
@@ -47,6 +54,8 @@ It has lots of other features though :
* The order of keys/sections is preserved
* Powerful ``unrepr`` mode for storing/retrieving Python data-types
+| Release 5.0.3 corrects errors related to the incorrectly handling unicode
+| encoding and writing out files
| Release 5.0.2 adds a specific error message when trying to install on
| Python versions older than 2.5
| Release 5.0.1 fixes a regression with unicode conversion not happening