summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorfuzzyman <devnull@localhost>2010-01-09 21:23:52 +0000
committerfuzzyman <devnull@localhost>2010-01-09 21:23:52 +0000
commit65e136a90b0c6c3ed55ffe2d8e55acefa51a96b2 (patch)
tree55f9bad41060a6f13c2149da59533ee942d3ae74 /setup.py
parent3a402cec71810bdf2179d7c913e329eac59f1f02 (diff)
downloadconfigobj-git-65e136a90b0c6c3ed55ffe2d8e55acefa51a96b2.tar.gz
ConfigObj setup.py modified.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py71
1 files changed, 58 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index 722f99a..3e7744c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
# setup.py
# Install script for ConfigObj
-# Copyright (C) 2005-2009 Michael Foord, Mark Andrews, Nicola Larosa
+# Copyright (C) 2005-2010 Michael Foord, Mark Andrews, Nicola Larosa
# E-mail: fuzzyman AT voidspace DOT org DOT uk
# mark AT la-la DOT com
# nico AT tekNico DOT net
@@ -13,19 +13,64 @@ from distutils.core import setup
from configobj import __version__ as VERSION
NAME = 'configobj'
+
MODULES = 'configobj', 'validate'
+
DESCRIPTION = 'Config file reading, writing, and validation.'
+
URL = 'http://www.voidspace.org.uk/python/configobj.html'
-LICENSE = 'BSD'
-PLATFORMS = ["Platform Independent"]
-
-setup(name= NAME,
- version= VERSION,
- description= DESCRIPTION,
- license = LICENSE,
- platforms = PLATFORMS,
- author= 'Michael Foord & Nicola Larosa',
- author_email= 'fuzzyman@voidspace.org.uk',
- url= URL,
- py_modules = MODULES,
+
+DOWNLOAD_URL = "http://www.voidspace.org.uk/downloads/configobj-%s.zip" % VERSION
+
+LONG_DESCRIPTION = """**ConfigObj** is a simple but powerful config file reader and writer: an *ini
+file round tripper*. Its main feature is that it is very easy to use, with a
+straightforward programmer's interface and a simple syntax for config files.
+It has lots of other features though :
+
+* Nested sections (subsections), to any level
+* List values
+* Multiple line values
+* Full Unicode support
+* String interpolation (substitution)
+* Integrated with a powerful validation system
+
+ - including automatic type checking/conversion
+ - and allowing default values
+ - repeated sections
+
+* All comments in the file are preserved
+* The order of keys/sections is preserved
+* Powerful ``unrepr`` mode for storing/retrieving Python data-types
+
+Release 4.7.0 improves performance adds features for validation and
+fixes some bugs."""
+
+CLASSIFIERS = [
+ 'Development Status :: 6 - Mature',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Programming Language :: Python',
+ 'Operating System :: OS Independent',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+]
+
+AUTHOR = 'Michael Foord & Nicola Larosa'
+
+AUTHOR_EMAIL = 'fuzzyman@voidspace.org.uk'
+
+KEYWORDS = "config, ini, dictionary, application, admin, sysadmin, configuration, validation".split(', ')
+
+
+setup(name=NAME,
+ version=VERSION,
+ description=DESCRIPTION,
+ long_description=LONG_DESCRIPTION,
+ download_url=DOWNLOAD_URL,
+ author=AUTHOR,
+ author_email=AUTHOR_EMAIL,
+ url=URL,
+ py_modules=MODULES,
+ classifiers=CLASSIFIERS,
+ keywords=KEYWORDS
)