summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorfuzzyman <devnull@localhost>2009-04-16 22:07:16 +0000
committerfuzzyman <devnull@localhost>2009-04-16 22:07:16 +0000
commit8b0700a67a3e0f6a9b78c25f8773ad4182f396b3 (patch)
tree4fc546ac0c616a9b7227ee39582a92ba223872f8 /setup.py
parentff26600cabb1089ce8942261f6bc54eb8334293d (diff)
downloadconfigobj-git-8b0700a67a3e0f6a9b78c25f8773ad4182f396b3.tar.gz
doc changes
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py57
1 files changed, 20 insertions, 37 deletions
diff --git a/setup.py b/setup.py
index 7170656..722f99a 100644
--- a/setup.py
+++ b/setup.py
@@ -1,48 +1,31 @@
# setup.py
# Install script for ConfigObj
-# Copyright (C) 2005 Michael Foord, Mark Andrews, Nicola Larosa
+# Copyright (C) 2005-2009 Michael Foord, Mark Andrews, Nicola Larosa
# E-mail: fuzzyman AT voidspace DOT org DOT uk
# mark AT la-la DOT com
# nico AT tekNico DOT net
# This software is licensed under the terms of the BSD license.
# http://www.voidspace.org.uk/python/license.shtml
-# Basically you're free to copy, modify, distribute and relicense it,
-# So long as you keep a copy of the license with it.
-# Scripts maintained at http://www.voidspace.org.uk/python/index.shtml
-# For information about bugfixes, updates and support, please join the
-# Rest2Web mailing list:
-# http://lists.sourceforge.net/lists/listinfo/rest2web-develop
-# Comments, suggestions and bug reports welcome.
-"""
-**setup.py** for ``configobj`` and ``validate`` modules.
-"""
+import sys
+from distutils.core import setup
+from configobj import __version__ as VERSION
-if __name__ == '__main__':
- import sys
- from distutils.core import setup
- from configobj import __version__ as VERSION
+NAME = 'configobj'
+MODULES = 'configobj', 'validate'
+DESCRIPTION = 'Config file reading, writing, and validation.'
+URL = 'http://www.voidspace.org.uk/python/configobj.html'
+LICENSE = 'BSD'
+PLATFORMS = ["Platform Independent"]
- NAME = 'configobj'
- MODULES = 'configobj', 'validate'
- DESCRIPTION = 'Config file reading, writing, and validation.'
- URL = 'http://www.voidspace.org.uk/python/configobj.html'
- LICENSE = 'BSD'
- PLATFORMS = ["Platform Independent"]
-
- if sys.version < '2.2.3':
- from distutils.dist import DistributionMetadata
- DistributionMetadata.classifiers = None
- DistributionMetadata.download_url = None
-
- setup(name= NAME,
- version= VERSION,
- description= DESCRIPTION,
- license = LICENSE,
- platforms = PLATFORMS,
- author= 'Michael Foord & Nicola Larosa',
- author_email= 'fuzzyman@voidspace.org.uk',
- url= URL,
- py_modules = MODULES,
- )
+setup(name= NAME,
+ version= VERSION,
+ description= DESCRIPTION,
+ license = LICENSE,
+ platforms = PLATFORMS,
+ author= 'Michael Foord & Nicola Larosa',
+ author_email= 'fuzzyman@voidspace.org.uk',
+ url= URL,
+ py_modules = MODULES,
+ )