summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Wagner <daniel.wagner@bmw-carit.de>2013-06-17 15:14:41 +0200
committerPatrik Flykt <patrik.flykt@linux.intel.com>2013-06-19 10:36:53 +0300
commit030f578d95c4380725e63ec746243ac1569e0577 (patch)
tree48a3a659f4559aa802d2eb901d93648652627d17 /Makefile.am
parentd25b22ce45c8c274a9ee984e4d84b9b4f5e06794 (diff)
downloadconnman-030f578d95c4380725e63ec746243ac1569e0577.tar.gz
netlink-test: Add test program for netlink
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a51c64f4..2a309ec3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,6 +37,9 @@ else
gweb_sources += gweb/giognutls.h gweb/gionotls.c
endif
+shared_sources = src/shared/util.h src/shared/util.c \
+ src/shared/netlink.h src/shared/netlink.c
+
if DATAFILES
if NMCOMPAT
@@ -271,7 +274,7 @@ noinst_PROGRAMS += tools/supplicant-test \
tools/iptables-test tools/tap-test tools/wpad-test \
tools/stats-tool tools/private-network-test \
tools/session-test tools/iptables-unit \
- tools/dnsproxy-test
+ tools/dnsproxy-test tools/netlink-test
tools_supplicant_test_SOURCES = $(gdbus_sources) tools/supplicant-test.c \
tools/supplicant-dbus.h tools/supplicant-dbus.c \
@@ -319,6 +322,9 @@ tools_iptables_unit_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ @XTABLES_LIBS@ -ldl
tools_dnsproxy_test_SOURCES = tools/dnsproxy-test.c
tools_dnsproxy_test_LDADD = @GLIB_LIBS@
+tools_netlink_test_SOURCES =$(shared_sources) tools/netlink-test.c
+tools_netlink_test_LDADD = @GLIB_LIBS@
+
endif
test_scripts = test/get-state test/list-services \