summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Spielberger <christian.spielberger@gmail.com>2018-05-15 12:35:08 +0200
committerDaniel Wagner <wagi@monom.org>2018-05-24 22:17:38 +0200
commit9c8e700742598316aae7e13ed3737b5dddab5ac6 (patch)
treeef9bf7d7622c998d38690131278c7b095bff78b6 /Makefile.am
parent026ec02f78e9812a907044013095afbd4c5138ba (diff)
downloadconnman-9c8e700742598316aae7e13ed3737b5dddab5ac6.tar.gz
util: Add function __connman_util_random_delay_ms
ACD needs random IPv4 addresses as fallback (IPv4LL address) and random delays between sent ARP probe and ARP announce packets. Hence, this patch moves ipv4ll_random_delay_ms() to src/util.c in order to be available generally. It replaces the calls of the obsolete function in gdhcp/client.c.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index c94164f7..edd19697 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,6 +32,10 @@ gdbus_libgdbus_internal_la_SOURCES = gdbus/gdbus.h \
gdbus/mainloop.c gdbus/watch.c \
gdbus/object.c gdbus/client.c gdbus/polkit.c
+if BACKTRACE
+backtrace_sources = src/backtrace.c
+endif
+
gdhcp_sources = gdhcp/gdhcp.h gdhcp/common.h gdhcp/common.c gdhcp/client.c \
gdhcp/server.c gdhcp/ipv4ll.h gdhcp/ipv4ll.c gdhcp/unaligned.h
@@ -355,11 +359,13 @@ tools_wpad_test_LDADD = @GLIB_LIBS@ -lresolv
tools_stats_tool_LDADD = @GLIB_LIBS@
-tools_dhcp_test_SOURCES = $(gdhcp_sources) tools/dhcp-test.c
-tools_dhcp_test_LDADD = @GLIB_LIBS@
+tools_dhcp_test_SOURCES = $(backtrace_sources) src/log.c \
+ src/util.c $(gdhcp_sources) tools/dhcp-test.c
+tools_dhcp_test_LDADD = @GLIB_LIBS@ -ldl
-tools_dhcp_server_test_SOURCES = $(gdhcp_sources) tools/dhcp-server-test.c
-tools_dhcp_server_test_LDADD = @GLIB_LIBS@
+tools_dhcp_server_test_SOURCES = $(backtrace_sources) src/log.c src/util.c \
+ $(gdhcp_sources) tools/dhcp-server-test.c
+tools_dhcp_server_test_LDADD = @GLIB_LIBS@ -ldl
tools_dbus_test_SOURCES = tools/dbus-test.c
tools_dbus_test_LDADD = gdbus/libgdbus-internal.la @GLIB_LIBS@ @DBUS_LIBS@