summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Wagner <wagi@monom.org>2019-07-19 10:44:44 +0200
committerDaniel Wagner <wagi@monom.org>2019-11-07 08:53:11 +0100
commit3f156e39cb79e2e60ec88cab87692dab5153efd6 (patch)
tree62de956ed55a298809e11588a4074e17dad8629a /configure.ac
parentdc9d71aacbc1317755097b454d3219522e726005 (diff)
downloadconnman-3f156e39cb79e2e60ec88cab87692dab5153efd6.tar.gz
shared: Add Generic Netlink helpers for libmnl
mnlg.c and mnlg.h are a copy from iproute2. The call to nl_dump_ext_ack() and nl_dump_ext_ack_done() have been removed from the code to avoid additional dependencies. git://git.kernel.org/pub/scm/network/iproute2/iproute2.git d035cc1b4e83e2589ea2115cdc2fa7c6d3693a5a The helpers are needed for the WireGuard VPN plugin.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 537ba5f4..3695ef5b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,7 +288,8 @@ fi
AM_CONDITIONAL(XTABLES, test "${found_iptables}" != "no")
found_libmnl="no"
-if (test "${firewall_type}" = "nftables"); then
+if (test "${firewall_type}" = "nftables" -o \
+ "${enable_wireguard}" != "no"); then
PKG_CHECK_MODULES(LIBMNL, [libmnl >= 1.0.0], [found_libmnl="yes"],
AC_MSG_ERROR([libmnl >= 1.0.0 not found]))
AC_SUBST(LIBMNL_CFLAGS)