summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew McRae <amcrae@google.com>2022-03-10 13:53:08 +1100
committerCommit Bot <commit-bot@chromium.org>2022-03-10 07:49:22 +0000
commit8bf3881676f207cba4d8bad52af63add72464f9a (patch)
treebf72a7c78b3c4da3a9066d756a3a988bd80ba6f8 /zephyr/CMakeLists.txt
parent4cd95ce28ba93a8f54ec60deb5b6584799a9cc53 (diff)
downloadchrome-ec-8bf3881676f207cba4d8bad52af63add72464f9a.tar.gz
zephyr: Add subsys under the app library
Add the subsys directory under the app library so that the include paths are correctly set. Also change the source file additions to add them to a library rather than zephyr_sources, which will attempt to build them as a zephyr main file. BUG=b:223697679 TEST=zmake build nivviks BRANCH=none Signed-off-by: Andrew McRae <amcrae@google.com> Change-Id: I2b7f7e17c532462b49dfb1c23b5fc11bd9109530 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3514429 Reviewed-by: Peter Marheine <pmarheine@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 9968866c44..02411ecdbb 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -106,6 +106,8 @@ if (DEFINED CONFIG_PLATFORM_EC)
"${PLATFORM_EC}/third_party")
endif()
+add_subdirectory("subsys")
+
# Creates a phony target all.libraries in case you only want to build the
# libraries and not the binaries. For example for creating the initial zero
# coverage files.
@@ -509,5 +511,4 @@ add_subdirectory(linker)
add_subdirectory("app")
add_subdirectory("drivers")
add_subdirectory("emul")
-add_subdirectory("subsys")
add_subdirectory_ifdef(CONFIG_PLATFORM_EC "shim")