summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorManoj Gupta <manojgupta@google.com>2022-06-27 17:05:05 +0000
committerChromeos LUCI <chromeos-scoped@luci-project-accounts.iam.gserviceaccount.com>2022-06-27 19:36:53 +0000
commitdd55312e6f8d6d6ec92ced1851ac131e89b14c1b (patch)
tree5f8eb82d51da685bd41628b8f1e51b25ccd4d585 /zephyr/CMakeLists.txt
parent6157536779a62334a16b1f1d406558ab25c6cb77 (diff)
downloadchrome-ec-dd55312e6f8d6d6ec92ced1851ac131e89b14c1b.tar.gz
zephyr: Disable position independent code
Zephyr does not handle position independent code so disable it. BUG=b:237245366 TEST=zmake build -a BRANCH=none Signed-off-by: Manoj Gupta <manojgupta@google.com> Change-Id: I0e036b617c8ef79139df69f799b3debccacebb6f Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3726956 Tested-by: Manoj Gupta <manojgupta@chromium.org> Reviewed-by: Jeremy Bettis <jbettis@chromium.org> Auto-Submit: Manoj Gupta <manojgupta@chromium.org> Commit-Queue: Jeremy Bettis <jbettis@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 451406c8b3..fbee307dc4 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -65,6 +65,8 @@ endif()
# Set extra compiler flags.
zephyr_cc_option(-mno-unaligned-access)
+zephyr_cc_option(-fno-PIC)
+
if (DEFINED CONFIG_RISCV)
zephyr_cc_option(-fsanitize=integer-divide-by-zero)
zephyr_cc_option(-fsanitize-undefined-trap-on-error)