summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorVijay Hiremath <vijay.p.hiremath@intel.com>2022-05-23 12:29:26 -0700
committerChromeos LUCI <chromeos-scoped@luci-project-accounts.iam.gserviceaccount.com>2022-05-26 22:17:52 +0000
commite7ba53ffc045ec6a152674e15e48d51a09d675d6 (patch)
tree600b4980d4b0ff8b0f3bf79e4f0661ff10bcc7b3 /zephyr/CMakeLists.txt
parent7ad7c9c9ca974dfbaa3e82337d38523b2385cd31 (diff)
downloadchrome-ec-e7ba53ffc045ec6a152674e15e48d51a09d675d6.tar.gz
usbc: cleanup: Abstract the TCPM control logic
Abstract the TCPM control logic to support various combinations of TCPC chips that support built in PPC and OCP. BUG=none BRANCH=none TEST=make buildall -j, zmake testall Change-Id: I614797829d1d8f230439a70c1822c918f9fea1f3 Signed-off-by: Vijay Hiremath <vijay.p.hiremath@intel.com> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3661521 Reviewed-by: Diana Z <dzigterman@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index f5e1c2572a..035dd126d8 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -386,6 +386,7 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PORT_POWER_SMART
"${PLATFORM_EC}/common/usb_port_power_smart.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_POWER_DELIVERY
+ "${PLATFORM_EC}/common/typec_control.c"
"${PLATFORM_EC}/common/usb_common.c"
"${PLATFORM_EC}/common/usb_pd_pdo.c"
"${PLATFORM_EC}/common/usbc/usbc_task.c"