summaryrefslogtreecommitdiff
path: root/zephyr/projects/intelrvp/CMakeLists.txt
diff options
context:
space:
mode:
authorRajesh Kumar <rajesh3.kumar@intel.com>2022-01-18 15:01:03 -0800
committerCommit Bot <commit-bot@chromium.org>2022-02-07 19:16:15 +0000
commitbc39f009000b9be8b8f486b22615c151afec0822 (patch)
tree334e698eb8a60bd6e3bb79ec25c24320df1ac110 /zephyr/projects/intelrvp/CMakeLists.txt
parent2ea7de8fe1ec029d004026b773640f507efe6654 (diff)
downloadchrome-ec-bc39f009000b9be8b8f486b22615c151afec0822.tar.gz
zephyr: adlrvp: Initial commit to enable zephyr
This enables zephyr build for ADL RVP NPCX9. BUG=none BRANCH=none TEST=zmake configure -B ~/tmp/adlrvp_npcx/ adlrvp_npcx -b EC boots up and uart console is accessible Signed-off-by: Rajesh Kumar <rajesh3.kumar@intel.com> Change-Id: I8c31ff25b2e0f80544bbfac4b800c81314dbc1d1 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3402624 Reviewed-by: Jack Rosenthal <jrosenth@chromium.org>
Diffstat (limited to 'zephyr/projects/intelrvp/CMakeLists.txt')
-rw-r--r--zephyr/projects/intelrvp/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/zephyr/projects/intelrvp/CMakeLists.txt b/zephyr/projects/intelrvp/CMakeLists.txt
new file mode 100644
index 0000000000..7b8cdde779
--- /dev/null
+++ b/zephyr/projects/intelrvp/CMakeLists.txt
@@ -0,0 +1,10 @@
+# Copyright 2022 The Chromium OS Authors. All rights reserved.
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
+
+cmake_minimum_required(VERSION 3.13.1)
+
+find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
+project(intelrvp)
+
+zephyr_include_directories(include)