summaryrefslogtreecommitdiff
path: root/zephyr/linker/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/linker/CMakeLists.txt')
-rw-r--r--zephyr/linker/CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/zephyr/linker/CMakeLists.txt b/zephyr/linker/CMakeLists.txt
deleted file mode 100644
index 71955c6d9d..0000000000
--- a/zephyr/linker/CMakeLists.txt
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 2021 The Chromium OS Authors. All rights reserved.
-# Use of this source code is governed by a BSD-style license that can be
-# found in the LICENSE file.
-
-# Add the fixed sections to the output image.
-zephyr_linker_sources(ROM_START SORT_KEY 1 fixed-sections.ld)
-
-# Support protection of part of the internal RAM
-zephyr_linker_sources(RWDATA SORT_KEY 1 iram_text.ld)
-
-# Compute the image size
-zephyr_linker_sources(RAM_SECTIONS image_size.ld)
-
-# Little FW with specific purposes used by NPCX EC
-zephyr_linker_sources_ifdef(CONFIG_SOC_FAMILY_NPCX ROM_START SORT_KEY 1
- npcx-lfw.ld)
-
-zephyr_linker_sources(DATA_SECTIONS iterables-ram.ld)
-zephyr_linker_sources(SECTIONS iterables-rom.ld)