summaryrefslogtreecommitdiff
path: root/zephyr/program/nissa/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/program/nissa/CMakeLists.txt')
-rw-r--r--zephyr/program/nissa/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/zephyr/program/nissa/CMakeLists.txt b/zephyr/program/nissa/CMakeLists.txt
index 88e2d1c8a4..3888d3f688 100644
--- a/zephyr/program/nissa/CMakeLists.txt
+++ b/zephyr/program/nissa/CMakeLists.txt
@@ -122,3 +122,13 @@ if(DEFINED CONFIG_BOARD_ULDREN)
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC "uldren/src/usbc.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_CHARGER "uldren/src/charger.c")
endif()
+if(DEFINED CONFIG_BOARD_GOTHRAX)
+ project(gothrax)
+ zephyr_library_sources(
+ "src/led.c"
+ "gothrax/src/keyboard.c"
+ "gothrax/src/hdmi.c"
+ )
+ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC "gothrax/src/usbc.c")
+ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_CHARGER "gothrax/src/charger.c")
+endif()