summaryrefslogtreecommitdiff
path: root/zephyr/program/skyrim/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/program/skyrim/CMakeLists.txt')
-rw-r--r--zephyr/program/skyrim/CMakeLists.txt43
1 files changed, 0 insertions, 43 deletions
diff --git a/zephyr/program/skyrim/CMakeLists.txt b/zephyr/program/skyrim/CMakeLists.txt
deleted file mode 100644
index bb1bde51a8..0000000000
--- a/zephyr/program/skyrim/CMakeLists.txt
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2021 The ChromiumOS Authors
-# Use of this source code is governed by a BSD-style license that can be
-# found in the LICENSE file.
-
-cmake_minimum_required(VERSION 3.13.1)
-
-find_package(Zephyr REQUIRED HINTS "${ZEPHYR_BASE}")
-
-zephyr_library_sources("src/common.c")
-zephyr_library_sources("src/power_signals.c")
-
-zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC
- "src/usb_pd_policy.c"
- "src/usbc_config.c")
-zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_LED_COMMON
- "src/led.c")
-zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_AMD_STT
- "src/stt.c")
-
-if(DEFINED CONFIG_BOARD_MORTHAL)
- project(morthal)
- add_subdirectory(morthal)
-endif()
-
-if(DEFINED CONFIG_BOARD_SKYRIM)
- project(skyrim)
- add_subdirectory(skyrim)
-endif()
-
-if(DEFINED CONFIG_BOARD_WINTERHOLD)
- project(winterhold)
- add_subdirectory(winterhold)
-endif()
-
-if(DEFINED CONFIG_BOARD_FROSTFLOW)
- project(frostflow)
- add_subdirectory(frostflow)
-endif()
-
-if(DEFINED CONFIG_BOARD_CRYSTALDRIFT)
- project(crystaldrift)
- add_subdirectory(crystaldrift)
-endif()