summaryrefslogtreecommitdiff
path: root/zephyr/projects/nissa/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/projects/nissa/CMakeLists.txt')
-rw-r--r--zephyr/projects/nissa/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/zephyr/projects/nissa/CMakeLists.txt b/zephyr/projects/nissa/CMakeLists.txt
new file mode 100644
index 0000000000..fae80277f9
--- /dev/null
+++ b/zephyr/projects/nissa/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Copyright 2021 The Chromium OS Authors. All rights reserved.
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
+
+cmake_minimum_required(VERSION 3.13.1)
+
+find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
+
+zephyr_include_directories(include)
+
+if(DEFINED CONFIG_BOARD_NIVVIKS)
+ project(nivviks)
+ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC "src/usbc.c")
+ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_CHARGER "src/charger.c")
+endif()
+if(DEFINED CONFIG_BOARD_NEREID)
+ project(nereid)
+endif()