summaryrefslogtreecommitdiff
path: root/zephyr/subsys/ap_pwrseq/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/subsys/ap_pwrseq/CMakeLists.txt')
-rw-r--r--zephyr/subsys/ap_pwrseq/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/zephyr/subsys/ap_pwrseq/CMakeLists.txt b/zephyr/subsys/ap_pwrseq/CMakeLists.txt
index e4b4ad1df9..a3f183f02b 100644
--- a/zephyr/subsys/ap_pwrseq/CMakeLists.txt
+++ b/zephyr/subsys/ap_pwrseq/CMakeLists.txt
@@ -14,6 +14,9 @@ zephyr_library_sources_ifdef(CONFIG_AP_PWRSEQ_SIGNAL_GPIO signal_gpio.c)
zephyr_library_sources_ifdef(CONFIG_AP_PWRSEQ_SIGNAL_VW signal_vw.c)
zephyr_library_sources_ifdef(CONFIG_AP_PWRSEQ_SIGNAL_ADC signal_adc.c)
+zephyr_library_sources_ifdef(CONFIG_AP_PWRSEQ_DRIVER ap_pwrseq.c)
+zephyr_library_sources_ifdef(CONFIG_AP_PWRSEQ_DRIVER ap_pwrseq_sm.c)
+
zephyr_library_sources_ifdef(CONFIG_X86_NON_DSX_PWRSEQ
x86_non_dsx_common_pwrseq_sm_handler.c
x86_non_dsx_chipset_power_state.c)