summaryrefslogtreecommitdiff
path: root/zephyr/test/accel_cal/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/test/accel_cal/CMakeLists.txt')
-rw-r--r--zephyr/test/accel_cal/CMakeLists.txt24
1 files changed, 0 insertions, 24 deletions
diff --git a/zephyr/test/accel_cal/CMakeLists.txt b/zephyr/test/accel_cal/CMakeLists.txt
deleted file mode 100644
index 14fd70e01a..0000000000
--- a/zephyr/test/accel_cal/CMakeLists.txt
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 2021 The Chromium OS Authors. All rights reserved.
-# Use of this source code is governed by a BSD-style license that can be
-# found in the LICENSE file.
-
-cmake_minimum_required(VERSION 3.13.1)
-find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
-project(accel_cal)
-
-# Ensure that we get the definitions from test_config.h
-zephyr_compile_definitions("TEST_ACCEL_CAL")
-
-# Include the local test directory for shimmed_test_tasks.h
-zephyr_include_directories("${CMAKE_CURRENT_SOURCE_DIR}")
-
-# Include test file and unit under test
-target_sources(app PRIVATE
- "${PLATFORM_EC}/test/accel_cal.c"
- "${PLATFORM_EC}/common/accel_cal.c"
- "${PLATFORM_EC}/common/kasa.c"
- "${PLATFORM_EC}/common/mat44.c"
- "${PLATFORM_EC}/common/math_util.c"
- "${PLATFORM_EC}/common/newton_fit.c"
- "${PLATFORM_EC}/common/stillness_detector.c"
- "${PLATFORM_EC}/common/vec3.c")