summaryrefslogtreecommitdiff
path: root/zephyr/test/drivers/console_cmd_mfallow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/test/drivers/console_cmd_mfallow/CMakeLists.txt')
-rw-r--r--zephyr/test/drivers/console_cmd_mfallow/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/zephyr/test/drivers/console_cmd_mfallow/CMakeLists.txt b/zephyr/test/drivers/console_cmd_mfallow/CMakeLists.txt
new file mode 100644
index 0000000000..abaf5246ba
--- /dev/null
+++ b/zephyr/test/drivers/console_cmd_mfallow/CMakeLists.txt
@@ -0,0 +1,15 @@
+# Copyright 2023 The ChromiumOS Authors
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
+
+# Create library name based on current directory
+zephyr_library_get_current_dir_lib_name(${ZEPHYR_BASE} lib_name)
+
+# Create interface library
+zephyr_interface_library_named(${lib_name})
+
+# Add source files
+zephyr_library_sources("${CMAKE_CURRENT_SOURCE_DIR}/src/console_cmd_mfallow.c")
+
+# Link in the library
+zephyr_library_link_libraries(${lib_name})