summaryrefslogtreecommitdiff
path: root/zephyr/test/krabby/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/test/krabby/CMakeLists.txt')
-rw-r--r--zephyr/test/krabby/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/zephyr/test/krabby/CMakeLists.txt b/zephyr/test/krabby/CMakeLists.txt
new file mode 100644
index 0000000000..eba91a7be4
--- /dev/null
+++ b/zephyr/test/krabby/CMakeLists.txt
@@ -0,0 +1,14 @@
+# Copyright 2022 The ChromiumOS Authors
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
+
+cmake_minimum_required(VERSION 3.13.1)
+find_package(Zephyr REQUIRED HINTS "${ZEPHYR_BASE}")
+project(krabby)
+
+zephyr_include_directories("${PLATFORM_EC}/zephyr/projects/corsola/include")
+
+target_sources(app PRIVATE
+ src/charger_workaround.c
+ src/stubs.c
+ ${PLATFORM_EC}/zephyr/projects/corsola/src/krabby/charger_workaround.c)