summaryrefslogtreecommitdiff
path: root/board/reef
Commit message (Expand)AuthorAgeFilesLines
* board/reef: Fix temp sensor gpiosTom Hughes2022-10-281-2/+2
* tree: Enable warning for fallthrough in switch statementsTom Hughes2022-10-191-1/+1
* tree: Disable false positive warning when building with clangTom Hughes2022-10-151-0/+3
* reef: usb_mux: Split struct usb_mux in reef boardsTomasz Michalec2022-09-131-8/+12
* Update license boilerplate text in source code filesMike Frysinger2022-09-128-8/+8
* charge_state: Add PWR_STATE_FORCED_IDLE stateParth Malkan2022-08-181-8/+7
* util: remove unused includesYuval Peress2022-08-051-0/+1
* board/reef/battery.c: Format with clang-formatJack Rosenthal2022-07-011-26/+31
* board/reef/board.c: Format with clang-formatJack Rosenthal2022-07-011-91/+74
* board/reef/led.c: Format with clang-formatJack Rosenthal2022-07-011-9/+13
* board/reef/board.h: Format with clang-formatJack Rosenthal2022-07-011-31/+29
* board/reef/usb_pd_policy.c: Format with clang-formatJack Rosenthal2022-06-291-5/+6
* board/baseboard: Remove ACCEL_INTERRUPTSGwendal Grignou2022-05-231-1/+0
* lid_switch: Move LID_DEBOUNCE_US to public headerJack Rosenthal2022-05-021-1/+0
* TCPM: Change the PS8xxx I2C flags name to match the driverSam Hurst2022-02-101-2/+2
* i2c: Use declared initializers for i2c_ports: reef boardsKeith Short2021-11-301-10/+35
* config: rename CONFIG_HOSTCMD_SHI to CONFIG_HOST_INTERFACE_SHIKeith Short2021-11-191-1/+2
* config: rename CONFIG_HOSTCMD_LPC to CONFIG_HOST_INTERFACE_LPCKeith Short2021-11-191-1/+1
* board: Rename RSMRST_L_PGOOD as PG_EC_RSMRST_ODLfirmware-chameleon-14280.B-mainDivya Sasidharan2021-10-121-0/+1
* USB MUX: Update mux HPD update interface to use mux_state_tDiana Z2021-09-161-1/+2
* adc: Remove adc_chip.h where adc.h is usedCaveh Jalali2021-08-271-1/+0
* lid_angle: Create a common callback for lid angle changesWai-Hong Tam2021-08-051-3/+1
* COIL: Change host interface option to CONFIG_HOSTCMD_SHIKeith Short2021-08-031-1/+1
* tablet_mode: Fix the race condition of setting the tablet modeWai-Hong Tam2021-07-231-1/+2
* keyboard: Use __override for keyboard_scan_configDaisuke Nojiri2021-07-232-2/+2
* system: Clean up system_get_board_version()Philip Chen2021-07-091-1/+0
* chgstv2: Unify power-on and shutdown battery thresholdsDaisuke Nojiri2021-06-231-0/+1
* thermisor: move header to include dirDawid Niedzwiecki2021-04-221-1/+1
* genvif: Use VIF overrides by defaultAbe Levkoy2021-03-301-0/+3
* config: Provide default VCONN Swap delayAbe Levkoy2021-01-221-1/+0
* config: Make VCONN Swap delay a documented optionAbe Levkoy2021-01-221-1/+1
* Refactor CONFIG_FLASH_SIZE to CONFIG_FLASH_SIZE_BYTESYuval Peress2021-01-151-1/+1
* task_set_event: remove the wait argumentDawid Niedzwiecki2020-12-141-1/+1
* COIL: Rename CONFIG_I2C_CONTROLLERDiana Z2020-11-051-1/+1
* Charger: Add dynamic charger chip countDiana Z2020-07-111-1/+0
* Swap system_jumped_to_this_image with system_jumped_latestabilize-quickfix-13310.91.B-masterstabilize-quickfix-13310.76.B-masterstabilize-quickfix-13310.73.B-masterstabilize-13310.99.B-masterstabilize-13310.94.B-masterstabilize-13310.83.B-masterstabilize-13310.74.B-masterstabilize-13310.72.B-masterrelease-R85-13310.B-masterDaisuke Nojiri2020-06-261-1/+1
* PD: Remove unnecessary PDCMD taskDiana Z2020-05-201-1/+0
* usb_pd: Rename CONFIG_CMD_PD_CONTROL to CONFIG_HOSTCMD_PD_CONTROLVijay Hiremath2020-05-151-1/+1
* Various boards: Shrink UART Tx buffer to save spaceAbe Levkoy2020-05-011-0/+2
* driver: Replace BMI160 to BMI in board configChing-Kang Yen2020-04-232-7/+7
* usb_mux: retimer: mux as chained mux and retimerDenis Brockus2020-02-281-9/+8
* TCPMV1/2: Make the PD Config Flags more consistentSam Hurst2020-02-221-0/+1
* Temp sensor: Remove action_delay_sec fieldDiana Z2020-02-141-7/+3
* Charger: Convert boards to use new driver structureDiana Z2020-02-041-0/+9
* Charger: change get_vbus_voltage to return EC errorDiana Z2020-01-281-1/+6
* board: Set Accelerometer range to 4gGwendal Grignou2019-12-171-2/+2
* usb_pd_policy: Make a lot of objects commonAseda Aboagye2019-12-101-313/+1
* Rename CONFIG_USB_PD_PORT_COUNT as CONFIG_USB_PD_PORT_MAX_COUNTKarthikeyan Ramasubramanian2019-11-013-8/+9
* usb_pd: use enum tcpc_rp_value instead of intCaveh Jalali2019-10-311-1/+1
* config: Merge CONFIG_CHARGER_V2 into CONFIG_CHARGERKeith Short2019-09-181-1/+0