summaryrefslogtreecommitdiff
path: root/gnulib-tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gnulib-tests/Makefile.am')
-rw-r--r--gnulib-tests/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnulib-tests/Makefile.am b/gnulib-tests/Makefile.am
new file mode 100644
index 0000000..edaa0a7
--- /dev/null
+++ b/gnulib-tests/Makefile.am
@@ -0,0 +1,20 @@
+include gnulib.mk
+
+AM_CFLAGS = $(GNULIB_TEST_WARN_CFLAGS) $(WERROR_CFLAGS)
+
+# A few tests are inherently warning-evoking.
+# In the typical case where we use -Werror, exempt the few offenders.
+
+# test-xvasprintf.c: In function 'test_xasprintf':
+# test-xvasprintf.c:100: error: format not a string literal and no \
+# format arguments [-Wformat-security]
+test_xvasprintf_CFLAGS = $(AM_CFLAGS) \
+ `test -n '$(WERROR_CFLAGS)' && echo ' -Wno-format-security'`
+
+# test-lock.c: In function 'lock_mutator_thread':
+# test-lock.c:148: error: cast from function call of type 'pthread_t' to \
+# non-matching type 'void *' [-Wbad-function-cast]
+test_lock_CFLAGS = $(AM_CFLAGS) \
+ `test -n '$(WERROR_CFLAGS)' && echo ' -Wno-bad-function-cast'`
+test_tls_CFLAGS = $(AM_CFLAGS) \
+ `test -n '$(WERROR_CFLAGS)' && echo ' -Wno-bad-function-cast'`