summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..cfa22be
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,38 @@
+## Makefile for gnulib/lib -*-Makefile-*-
+
+# Copyright (C) 1995-2006 Free Software Foundation, Inc.
+
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
+
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+## 02110-1301, USA.
+
+include gnulib.mk
+
+AM_CFLAGS = $(WARNING_CFLAGS) $(WERROR_CFLAGS)
+
+noinst_PROGRAMS = t-fpending
+LDADD = $(noinst_LIBRARIES)
+
+libcoreutils_a_SOURCES += \
+ buffer-lcm.c buffer-lcm.h \
+ xmemxfrm.c xmemxfrm.h
+
+libcoreutils_a_LIBADD += $(LIBOBJS)
+libcoreutils_a_DEPENDENCIES += $(LIBOBJS)
+
+check: unit-test
+
+.PHONY: unit-test
+unit-test: t-fpending
+ ./t-fpending > /dev/null