summaryrefslogtreecommitdiff
path: root/tests/tail-2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tail-2/Makefile.am')
-rw-r--r--tests/tail-2/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/tail-2/Makefile.am b/tests/tail-2/Makefile.am
new file mode 100644
index 0000000..e038a1b
--- /dev/null
+++ b/tests/tail-2/Makefile.am
@@ -0,0 +1,34 @@
+# Make coreutils tests for "tail". -*-Makefile-*-
+
+# Copyright (C) 1999, 2000, 2001, 2002, 2003, 2006 Free Software
+# Foundation, Inc.
+
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+# 02110-1301, USA.
+
+EXTRA_DIST = $(TESTS)
+
+TESTS_ENVIRONMENT = \
+ top_srcdir=$(top_srcdir) \
+ srcdir=$(srcdir) \
+ PERL="$(PERL)" \
+ CU_TEST_NAME=`basename $(abs_srcdir)`,$$tst \
+ PATH="$(VG_PATH_PREFIX)`pwd`/../../src$(PATH_SEPARATOR)$$PATH" \
+ PROG=tail
+
+TESTS = \
+ append-only \
+ tail-n0f \
+ big-4gb proc-ksyms start-middle assert assert-2