summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPádraig Brady <P@draigBrady.com>2020-02-02 16:24:18 +0000
committerPádraig Brady <P@draigBrady.com>2020-02-03 19:38:02 +0000
commit709b4d9d8dc2d456a2209b5ef3d1aaf0f1f45a48 (patch)
tree8844362edb9a0dd905f583282e49658fb115a521 /configure.ac
parent18c9382801944a1673e3f9871e829cb8f0f30aeb (diff)
downloadcoreutils-709b4d9d8dc2d456a2209b5ef3d1aaf0f1f45a48.tar.gz
build: avoid vector performance warnings in randperm
* configure.ac: Add -Wno-vector-operation-performance to suppress the following gcc-9.2 error in gl/lib/randperm.c: error: vector operation will be expanded piecewise
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 54af03281..4eab50f1d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,6 +142,8 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wunsafe-loop-optimizations" # a few src/*.c
nw="$nw -Winline" # system.h's readdir_ignoring_dot_and_dotdot
nw="$nw -Wsuggest-attribute=format" # warns about copy.c and factor.c
+ nw="$nw -Wvector-operation-performance" # warns about randperm.c
+
# Using -Wstrict-overflow is a pain, but the alternative is worse.
# For an example, see the code that provoked this report: