summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPádraig Brady <P@draigBrady.com>2015-04-27 11:00:07 +0100
committerPádraig Brady <P@draigBrady.com>2015-04-27 11:00:07 +0100
commitb817f62769a3997bce5140f46bd117c48d208d78 (patch)
treeefd6c15f792bdc7234d69e57becb1945fab3d998 /configure.ac
parent0e7ac9a4609248663af76f202418dabf1c13efbe (diff)
downloadcoreutils-b817f62769a3997bce5140f46bd117c48d208d78.tar.gz
build: rely on gnulib to determine printf routines are safe
gnulib now only checks that the printf routines never crash, which is all coreutils currrently requires, and so we revert commit v8.23-81-gf57bfbb to let gnulib decide whether to replace the system printf routines.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index cac9ab2c5..e6086111d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,12 +67,6 @@ cu_have_perl=yes
case $PERL in *"/missing "*) cu_have_perl=no;; esac
AM_CONDITIONAL([HAVE_PERL], [test $cu_have_perl = yes])
-# Disable the checks for handling certain invalid long double values
-# since this results in always replacing the printf() implementation
-# (see https://sourceware.org/bugzilla/show_bug.cgi?id=17661) and
-# od (ftoastr) doesn't use the replacement anyway.
-m4_divert_text([INIT_PREPARE], [gl_printf_safe=''])
-
# gl_GCC_VERSION_IFELSE([major], [minor], [run-if-found], [run-if-not-found])
# ------------------------------------------------
# If $CPP is gcc-MAJOR.MINOR or newer, then run RUN-IF-FOUND.