summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 02b4bd11e..d6836d2b7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,8 +78,17 @@ NOTICE.gz: $(top_srcdir)/NOTICE
README.gz: $(top_srcdir)/README
-gzip -9 < $< > $@
+.PHONY: THANKS.gz
THANKS.gz: $(top_srcdir)/THANKS
- -gzip -9 < $< > $@
+ @sed -e '/^#.*/d' $< > $(top_builddir)/THANKS.tmp
+ @git shortlog -se 6c976bd..HEAD \
+ | grep -v @apache.org \
+ | sed -E 's/^[[:blank:]]{5}[[:digit:]]+[[:blank:]]/ * /' \
+ >> $(top_builddir)/THANKS.tmp
+ @echo '\nFor a list of authors see the `AUTHORS` file.\n' \
+ >> $(top_builddir)/THANKS.tmp
+ -gzip -9 < $(top_builddir)/THANKS.tmp > $@
+ @rm $(top_builddir)/THANKS.tmp
check: dev check-js
$(top_builddir)/test/etap/run $(top_srcdir)/test/etap
@@ -89,6 +98,9 @@ if USE_CURL
$(top_builddir)/test/javascript/run
endif
+check-etap: dev
+ $(top_builddir)/test/etap/run $(top_srcdir)/test/etap
+
cover: dev
rm -f cover/*.coverdata
COVER=1 COVER_BIN=./src/couchdb/ $(top_builddir)/test/etap/run