summaryrefslogtreecommitdiff
path: root/src/mochiweb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/mochiweb/Makefile.am')
-rw-r--r--src/mochiweb/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/mochiweb/Makefile.am b/src/mochiweb/Makefile.am
new file mode 100644
index 000000000..9de19441b
--- /dev/null
+++ b/src/mochiweb/Makefile.am
@@ -0,0 +1,29 @@
+
+PREFIX:=../
+DEST:=$(PREFIX)$(PROJECT)
+
+REBAR=./rebar
+
+all:
+ @$(REBAR) get-deps compile
+
+edoc:
+ @$(REBAR) doc
+
+test:
+ @rm -rf .eunit
+ @mkdir -p .eunit
+ @$(REBAR) skip_deps=true eunit
+
+clean:
+ @$(REBAR) clean
+
+build_plt:
+ @$(REBAR) build-plt
+
+dialyzer:
+ @$(REBAR) dialyze
+
+app:
+ @$(REBAR) create template=mochiwebapp dest=$(DEST) appid=$(PROJECT)
+