summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL83
1 files changed, 83 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..ca5bb37
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,83 @@
+
+# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v5.020.
+use strict;
+use warnings;
+
+use 5.006;
+
+use ExtUtils::MakeMaker ;
+
+
+
+my %WriteMakefileArgs = (
+ "ABSTRACT" => "create a minimal mirror of CPAN",
+ "AUTHOR" => "Ricardo SIGNES <rjbs\@cpan.org>, Randal Schwartz <merlyn\@stonehenge.com>",
+ "CONFIGURE_REQUIRES" => {
+ "ExtUtils::MakeMaker" => 0
+ },
+ "DISTNAME" => "CPAN-Mini",
+ "EXE_FILES" => [
+ "bin/minicpan"
+ ],
+ "LICENSE" => "perl",
+ "NAME" => "CPAN::Mini",
+ "PREREQ_PM" => {
+ "Carp" => 0,
+ "Compress::Zlib" => "1.20",
+ "File::Basename" => 0,
+ "File::Copy" => 0,
+ "File::Find" => 0,
+ "File::HomeDir" => "0.57",
+ "File::Path" => "2.04",
+ "File::Spec" => 0,
+ "File::Temp" => 0,
+ "Getopt::Long" => 0,
+ "LWP::UserAgent" => 5,
+ "Pod::Usage" => "1.00",
+ "URI" => 1,
+ "strict" => 0,
+ "warnings" => 0
+ },
+ "TEST_REQUIRES" => {
+ "Test::More" => "0.96"
+ },
+ "VERSION" => "1.111016",
+ "test" => {
+ "TESTS" => "t/*.t"
+ }
+);
+
+
+my %FallbackPrereqs = (
+ "Carp" => 0,
+ "Compress::Zlib" => "1.20",
+ "File::Basename" => 0,
+ "File::Copy" => 0,
+ "File::Find" => 0,
+ "File::HomeDir" => "0.57",
+ "File::Path" => "2.04",
+ "File::Spec" => 0,
+ "File::Temp" => 0,
+ "Getopt::Long" => 0,
+ "LWP::UserAgent" => 5,
+ "Pod::Usage" => "1.00",
+ "Test::More" => "0.96",
+ "URI" => 1,
+ "strict" => 0,
+ "warnings" => 0
+);
+
+
+unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
+ delete $WriteMakefileArgs{TEST_REQUIRES};
+ delete $WriteMakefileArgs{BUILD_REQUIRES};
+ $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
+}
+
+delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+
+WriteMakefile(%WriteMakefileArgs);
+
+
+