summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL76
1 files changed, 76 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..cd76505
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,76 @@
+
+# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v5.025.
+use strict;
+use warnings;
+
+use 5.006;
+
+use ExtUtils::MakeMaker;
+
+
+
+my %WriteMakefileArgs = (
+ "ABSTRACT" => "XS implementation of parts of Class::Load",
+ "AUTHOR" => "Dave Rolsky <autarch\@urth.org>",
+ "CONFIGURE_REQUIRES" => {
+ "ExtUtils::MakeMaker" => 0
+ },
+ "DISTNAME" => "Class-Load-XS",
+ "EXE_FILES" => [],
+ "LICENSE" => "artistic_2",
+ "MIN_PERL_VERSION" => "5.006",
+ "NAME" => "Class::Load::XS",
+ "PREREQ_PM" => {
+ "Class::Load" => "0.20",
+ "XSLoader" => 0,
+ "strict" => 0,
+ "warnings" => 0
+ },
+ "TEST_REQUIRES" => {
+ "ExtUtils::MakeMaker" => 0,
+ "File::Spec" => 0,
+ "Module::Implementation" => "0.04",
+ "Test::Fatal" => 0,
+ "Test::More" => "0.88",
+ "Test::Requires" => 0,
+ "constant" => 0,
+ "lib" => 0,
+ "version" => 0
+ },
+ "VERSION" => "0.09",
+ "test" => {
+ "TESTS" => "t/*.t"
+ }
+);
+
+
+my %FallbackPrereqs = (
+ "Class::Load" => "0.20",
+ "ExtUtils::MakeMaker" => 0,
+ "File::Spec" => 0,
+ "Module::Implementation" => "0.04",
+ "Test::Fatal" => 0,
+ "Test::More" => "0.88",
+ "Test::Requires" => 0,
+ "XSLoader" => 0,
+ "constant" => 0,
+ "lib" => 0,
+ "strict" => 0,
+ "version" => 0,
+ "warnings" => 0
+);
+
+
+unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
+ delete $WriteMakefileArgs{TEST_REQUIRES};
+ delete $WriteMakefileArgs{BUILD_REQUIRES};
+ $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
+}
+
+delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+
+WriteMakefile(%WriteMakefileArgs);
+
+
+