summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@lorry>2014-04-03 14:57:29 +0000
committerLorry Tar Creator <lorry-tar-importer@lorry>2014-04-03 14:57:29 +0000
commitdfaae12e4d85f7c6821ae4a9fbf7e463d570e7ba (patch)
tree6dcde6413d8dcd3d24b0251080c21c49fa5b81a6 /Makefile.PL
downloadDist-CheckConflicts-tarball-dfaae12e4d85f7c6821ae4a9fbf7e463d570e7ba.tar.gz
Dist-CheckConflicts-0.11HEADDist-CheckConflicts-0.11master
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL74
1 files changed, 74 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..5574783
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,74 @@
+
+# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v5.014.
+use strict;
+use warnings;
+
+use 5.006;
+
+use ExtUtils::MakeMaker 6.30;
+
+
+
+my %WriteMakefileArgs = (
+ "ABSTRACT" => "declare version conflicts for your dist",
+ "AUTHOR" => "Jesse Luehrs <doy\@tozt.net>",
+ "BUILD_REQUIRES" => {},
+ "CONFIGURE_REQUIRES" => {
+ "ExtUtils::MakeMaker" => "6.30"
+ },
+ "DISTNAME" => "Dist-CheckConflicts",
+ "EXE_FILES" => [],
+ "LICENSE" => "perl",
+ "NAME" => "Dist::CheckConflicts",
+ "PREREQ_PM" => {
+ "Carp" => 0,
+ "Exporter" => 0,
+ "Module::Runtime" => "0.009",
+ "base" => 0,
+ "strict" => 0,
+ "warnings" => 0
+ },
+ "TEST_REQUIRES" => {
+ "File::Spec" => 0,
+ "IO::Handle" => 0,
+ "IPC::Open3" => 0,
+ "Test::Fatal" => 0,
+ "Test::More" => "0.88",
+ "lib" => 0
+ },
+ "VERSION" => "0.11",
+ "test" => {
+ "TESTS" => "t/*.t"
+ }
+);
+
+
+my %FallbackPrereqs = (
+ "Carp" => 0,
+ "Exporter" => 0,
+ "File::Spec" => 0,
+ "IO::Handle" => 0,
+ "IPC::Open3" => 0,
+ "Module::Runtime" => "0.009",
+ "Test::Fatal" => 0,
+ "Test::More" => "0.88",
+ "base" => 0,
+ "lib" => 0,
+ "strict" => 0,
+ "warnings" => 0
+);
+
+
+unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
+ delete $WriteMakefileArgs{TEST_REQUIRES};
+ delete $WriteMakefileArgs{BUILD_REQUIRES};
+ $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
+}
+
+delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+
+WriteMakefile(%WriteMakefileArgs);
+
+
+