summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@lorry>2015-04-29 03:17:05 +0000
committerLorry Tar Creator <lorry-tar-importer@lorry>2015-04-29 03:17:05 +0000
commit2ca9db53e3e8164ecf0c95bf93fa289019e1b92c (patch)
tree5cc19083935ae762133417625e80a5329e36d8ee /Makefile.PL
downloadDist-Metadata-tarball-master.tar.gz
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL105
1 files changed, 105 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..12b1813
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,105 @@
+#
+# This file is part of Dist-Metadata
+#
+# This software is copyright (c) 2011 by Randy Stauner.
+#
+# This is free software; you can redistribute it and/or modify it under
+# the same terms as the Perl 5 programming language system itself.
+#
+# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v5.035.
+use strict;
+use warnings;
+
+use 5.006;
+
+use ExtUtils::MakeMaker;
+
+my %WriteMakefileArgs = (
+ "ABSTRACT" => "Information about a perl module distribution",
+ "AUTHOR" => "Randy Stauner <rwstauner\@cpan.org>",
+ "CONFIGURE_REQUIRES" => {
+ "ExtUtils::MakeMaker" => 0
+ },
+ "DISTNAME" => "Dist-Metadata",
+ "EXE_FILES" => [],
+ "LICENSE" => "perl",
+ "MIN_PERL_VERSION" => "5.006",
+ "NAME" => "Dist::Metadata",
+ "PREREQ_PM" => {
+ "Archive::Tar" => 1,
+ "Archive::Zip" => "1.30",
+ "CPAN::DistnameInfo" => "0.12",
+ "CPAN::Meta" => "2.1",
+ "Carp" => 0,
+ "Digest" => "1.03",
+ "Digest::MD5" => 2,
+ "Digest::SHA" => 5,
+ "File::Basename" => 0,
+ "File::Find" => 0,
+ "File::Spec::Native" => "1.002",
+ "File::Temp" => "0.19",
+ "List::Util" => 0,
+ "Module::Metadata" => 0,
+ "Path::Class" => "0.24",
+ "Try::Tiny" => "0.09",
+ "parent" => 0,
+ "strict" => 0,
+ "warnings" => 0
+ },
+ "TEST_REQUIRES" => {
+ "ExtUtils::MakeMaker" => 0,
+ "File::Spec" => 0,
+ "File::Temp" => "0.19",
+ "IO::Handle" => 0,
+ "IPC::Open3" => 0,
+ "Test::Fatal" => 0,
+ "Test::MockObject" => "1.09",
+ "Test::More" => "0.96"
+ },
+ "VERSION" => "0.926",
+ "test" => {
+ "TESTS" => "t/*.t"
+ }
+);
+
+
+my %FallbackPrereqs = (
+ "Archive::Tar" => 1,
+ "Archive::Zip" => "1.30",
+ "CPAN::DistnameInfo" => "0.12",
+ "CPAN::Meta" => "2.1",
+ "Carp" => 0,
+ "Digest" => "1.03",
+ "Digest::MD5" => 2,
+ "Digest::SHA" => 5,
+ "ExtUtils::MakeMaker" => 0,
+ "File::Basename" => 0,
+ "File::Find" => 0,
+ "File::Spec" => 0,
+ "File::Spec::Native" => "1.002",
+ "File::Temp" => "0.19",
+ "IO::Handle" => 0,
+ "IPC::Open3" => 0,
+ "List::Util" => 0,
+ "Module::Metadata" => 0,
+ "Path::Class" => "0.24",
+ "Test::Fatal" => 0,
+ "Test::MockObject" => "1.09",
+ "Test::More" => "0.96",
+ "Try::Tiny" => "0.09",
+ "parent" => 0,
+ "strict" => 0,
+ "warnings" => 0
+);
+
+
+unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
+ delete $WriteMakefileArgs{TEST_REQUIRES};
+ delete $WriteMakefileArgs{BUILD_REQUIRES};
+ $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
+}
+
+delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+
+WriteMakefile(%WriteMakefileArgs);