summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@lorry>2015-02-15 23:48:22 +0000
committerLorry Tar Creator <lorry-tar-importer@lorry>2015-02-15 23:48:22 +0000
commit2f62d65d28afdbbd6a417f8e3da3ac6143863ef8 (patch)
tree7753a0f1973f273a43897260a31416519967ff54 /Makefile.PL
downloadExtUtils-InstallPaths-tarball-master.tar.gz
ExtUtils-InstallPaths-0.011HEADExtUtils-InstallPaths-0.011master
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL72
1 files changed, 72 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..b465137
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,72 @@
+
+# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v5.025.
+use strict;
+use warnings;
+
+use 5.006;
+
+use ExtUtils::MakeMaker;
+
+
+
+my %WriteMakefileArgs = (
+ "ABSTRACT" => "Build.PL install path logic made easy",
+ "AUTHOR" => "Ken Williams <kwilliams\@cpan.org>, Leon Timmermans <leont\@cpan.org>",
+ "CONFIGURE_REQUIRES" => {
+ "ExtUtils::MakeMaker" => 0
+ },
+ "DISTNAME" => "ExtUtils-InstallPaths",
+ "EXE_FILES" => [],
+ "LICENSE" => "perl",
+ "MIN_PERL_VERSION" => "5.006",
+ "NAME" => "ExtUtils::InstallPaths",
+ "PREREQ_PM" => {
+ "Carp" => 0,
+ "ExtUtils::Config" => "0.002",
+ "File::Spec" => 0,
+ "strict" => 0,
+ "warnings" => 0
+ },
+ "TEST_REQUIRES" => {
+ "File::Spec" => 0,
+ "File::Spec::Functions" => "0.83",
+ "File::Temp" => 0,
+ "IO::Handle" => 0,
+ "IPC::Open3" => 0,
+ "Test::More" => 0
+ },
+ "VERSION" => "0.011",
+ "test" => {
+ "TESTS" => "t/*.t"
+ }
+);
+
+
+my %FallbackPrereqs = (
+ "Carp" => 0,
+ "ExtUtils::Config" => "0.002",
+ "ExtUtils::MakeMaker" => 0,
+ "File::Spec" => 0,
+ "File::Spec::Functions" => "0.83",
+ "File::Temp" => 0,
+ "IO::Handle" => 0,
+ "IPC::Open3" => 0,
+ "Test::More" => 0,
+ "strict" => 0,
+ "warnings" => 0
+);
+
+
+unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
+ delete $WriteMakefileArgs{TEST_REQUIRES};
+ delete $WriteMakefileArgs{BUILD_REQUIRES};
+ $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
+}
+
+delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+
+WriteMakefile(%WriteMakefileArgs);
+
+
+