summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..364dc45
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,22 @@
+use strict ;
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+WriteMakefile(
+ 'NAME' => 'File::Slurp',
+ 'LICENSE' => 'perl',
+ 'AUTHOR' => 'Uri Guttman <uri@stemsystems.com>',
+ 'VERSION_FROM' => 'lib/File/Slurp.pm',
+ 'ABSTRACT_FROM' => 'lib/File/Slurp.pm',
+ 'META_MERGE' => {
+ requires => {
+ perl => 5.004,
+ },
+ },
+ 'PREREQ_PM' => {
+ 'Carp' => 0,
+ 'Exporter' => 0,
+ 'Fcntl' => 0,
+ 'POSIX' => 0,
+ },
+);