summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@lorry>2012-02-15 22:16:13 +0000
committerLorry Tar Creator <lorry-tar-importer@lorry>2012-02-15 22:16:13 +0000
commit4861af5daed8f4ba6d0041aed25e98f403d96fc0 (patch)
tree2b19d8ec4b2179938143af9c3574ebeb6d6e84a6 /Makefile.PL
downloadHTTP-Cookies-tarball-4861af5daed8f4ba6d0041aed25e98f403d96fc0.tar.gz
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL48
1 files changed, 48 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..e868855
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,48 @@
+#!perl -w
+
+require 5.008001;
+use strict;
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'HTTP::Cookies',
+ VERSION_FROM => 'lib/HTTP/Cookies.pm',
+ ABSTRACT_FROM => 'lib/HTTP/Cookies.pm',
+ AUTHOR => 'Gisle Aas <gisle@activestate.com>',
+ LICENSE => "perl",
+ MIN_PERL_VERSION => 5.008001,
+ PREREQ_PM => {
+ 'HTTP::Date' => 6,
+ 'HTTP::Headers::Util' => 6,
+ 'Time::Local' => 0,
+ },
+ META_MERGE => {
+ resources => {
+ repository => 'http://github.com/gisle/http-cookies',
+ MailingList => 'mailto:libwww@perl.org',
+ }
+ },
+);
+
+
+BEGIN {
+ # compatibility with older versions of MakeMaker
+ my $developer = -f ".gitignore";
+ my %mm_req = (
+ LICENCE => 6.31,
+ META_MERGE => 6.45,
+ META_ADD => 6.45,
+ MIN_PERL_VERSION => 6.48,
+ );
+ undef(*WriteMakefile);
+ *WriteMakefile = sub {
+ my %arg = @_;
+ for (keys %mm_req) {
+ unless (eval { ExtUtils::MakeMaker->VERSION($mm_req{$_}) }) {
+ warn "$_ $@" if $developer;
+ delete $arg{$_};
+ }
+ }
+ ExtUtils::MakeMaker::WriteMakefile(%arg);
+ };
+}