summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@lorry>2014-08-24 16:36:19 +0000
committerLorry Tar Creator <lorry-tar-importer@lorry>2014-08-24 16:36:19 +0000
commitb808141b894ad538db75a7067e0199cbfe6337a9 (patch)
treeb3560724f86d6383c5ded5a79749c3f69592eb51 /Makefile.PL
downloadModule-Implementation-tarball-master.tar.gz
Module-Implementation-0.09HEADModule-Implementation-0.09master
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL75
1 files changed, 75 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..5857c49
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,75 @@
+
+# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v5.020.
+use strict;
+use warnings;
+
+
+
+use ExtUtils::MakeMaker ;
+
+
+
+my %WriteMakefileArgs = (
+ "ABSTRACT" => "Loads one of several alternate underlying implementations for a module",
+ "AUTHOR" => "Dave Rolsky <autarch\@urth.org>",
+ "CONFIGURE_REQUIRES" => {
+ "ExtUtils::MakeMaker" => 0
+ },
+ "DISTNAME" => "Module-Implementation",
+ "EXE_FILES" => [],
+ "LICENSE" => "artistic_2",
+ "NAME" => "Module::Implementation",
+ "PREREQ_PM" => {
+ "Carp" => 0,
+ "Module::Runtime" => "0.012",
+ "Try::Tiny" => 0,
+ "strict" => 0,
+ "warnings" => 0
+ },
+ "TEST_REQUIRES" => {
+ "ExtUtils::MakeMaker" => 0,
+ "File::Spec" => 0,
+ "IO::Handle" => 0,
+ "IPC::Open3" => 0,
+ "Test::Fatal" => "0.006",
+ "Test::More" => "0.88",
+ "Test::Requires" => 0,
+ "lib" => 0
+ },
+ "VERSION" => "0.09",
+ "test" => {
+ "TESTS" => "t/*.t"
+ }
+);
+
+
+my %FallbackPrereqs = (
+ "Carp" => 0,
+ "ExtUtils::MakeMaker" => 0,
+ "File::Spec" => 0,
+ "IO::Handle" => 0,
+ "IPC::Open3" => 0,
+ "Module::Runtime" => "0.012",
+ "Test::Fatal" => "0.006",
+ "Test::More" => "0.88",
+ "Test::Requires" => 0,
+ "Try::Tiny" => 0,
+ "lib" => 0,
+ "strict" => 0,
+ "warnings" => 0
+);
+
+
+unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
+ delete $WriteMakefileArgs{TEST_REQUIRES};
+ delete $WriteMakefileArgs{BUILD_REQUIRES};
+ $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
+}
+
+delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+
+WriteMakefile(%WriteMakefileArgs);
+
+
+